#1  
Alt 02.01.2017
pefo0001 pefo0001 ist offline
Trollanwärter
Registriert seit: 02.2012
Beiträge: 16
pefo0001 befindet sich auf einem aufstrebenden Ast
Standard Aktion: Volume und Film anlegen

Ich hab's geschafft, per Aktion ein neues Volume anzulegen. Leider geschieht das aber nicht vollständig:

newvol:=TIVolume.create;
newvol.Caption:='Titel des neuen Volumes';
newvol.Path:='Titel des neuen Volumes'+'\';
newvol.NoFilms:=true;
newvol.NoVolumes:=false;
newvol.Volume:=parentvol;
newvol.PathType:=2;
newvol.Append;

Bis hierher funktionierts!
Das Anlegen eines Films funktioniert
leider gar nicht:

newfilm:=TIFilm.create;
newfilm.Caption:='Titel des neuen Volumes';
newfilm.HideInTree:=true;
newfilm.NoImport:=false;
newfilm.Volume:=newvol;
newfilm.Append;

Es wird leider kein neuer Film angelegt, sondern es kommt die Fehlermeldung "null pointer exception"



Hat jemand eine Idee?
Peter
Mit Zitat antworten
 

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Volume, absolutes Volume, Film SFarkasch Imabas Allgemein 1 15.11.2010 15:32
Dialog 'Neue Aktion anlegen': MRU-Liste 'Gruppe' wird immer gespeichert Planlos Bugreports 1 26.05.2009 12:25
Erstellen von Unter-Volume bzw. 1 Volume pro Film hotze78 Imabas Allgemein 2 31.03.2008 14:41
V5.5 Volume anlegen helge Bugreports 2 06.04.2005 10:04
Abbruch bei anlegen neuer Film und Reorganisation Basti Bugreports 7 29.03.2004 20:58


Powered by vBulletin® Version 3.7.1 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.