#1  
Alt 18.02.2004
Basti Basti ist offline
Teilzeittroll
Registriert seit: 11.2003
Ort: Haiger, Deutschland
Beiträge: 96
Basti ist zur Zeit noch ein unbeschriebenes Blatt
Standard Abbruch bei anlegen neuer Film und Reorganisation

Hallo,
ich erlebe hier einen Abbruch beim Anlegen eines neuen Films mit folgender Meldung:
"Zugriffsverletzung bei ADresse 005D8A95 in Modul Imabas.exe. Lesen von ADresse 00000010"
Beim Reorganisieren ist nach zwei oder auch mehr Bildern schluß mit der Meldung " Zugrifsverletzung...(wie oben) Schwerwiedgender Fehler aufgetreten! Programm wird beendet."

Was ist das? Woran könnte das liegen? Eine neue Datenbank bringt diese Probleme nicht.Kann ich die alte in eine neue Importieren?

Gruß
Basti
  #2  
Alt 20.02.2004
Benutzerbild von Kai
Kai Kai ist offline
Imabas-Entwickler
Admin
Obertroll
Registriert seit: 11.2003
Ort: Holzwickede
Beiträge: 2.756
Kai befindet sich auf einem aufstrebenden Ast
Standard Re: Abbruch bei anlegen neuer Film und Reorganisation

Hallo Basti,
von einer Zugriffsverletzung beim anlegen eines Filmes habe ich noch nichts gehört, bist jetzt

Kannst du mir die BDB-Datei in gezippter Form mal per Mail zuschicken ?

Gruß, Kai
  #3  
Alt 21.02.2004
Benutzerbild von Kai
Kai Kai ist offline
Imabas-Entwickler
Admin
Obertroll
Registriert seit: 11.2003
Ort: Holzwickede
Beiträge: 2.756
Kai befindet sich auf einem aufstrebenden Ast
Standard Re: Abbruch bei anlegen neuer Film und Reorganisation

Hallo Basti,
das Problem ist das in Bildertabelle 40 Bilder "Geisterbilder" rumturnen, die keinem Film zugeordnet sind, wie das auch in immer passieren konnte

Folgendes musst du machen um die Datenbank wieder herzustellen:
Im SQL-Fenster:
Code:
update bilder set film = 'XXXX' where film = ''
Dann legst einen neuen Film an, und holst dir aus der Tabellen-Sicht das Feld ukey des neuen Filmes und trägst in das Feld bilder den Wert 40 ein und dann "Cursor einmal rauf" damit die änderungen am Film übernommen werden und gehst wieder ins SQL-Fenster:
Code:
update bilder set film = 'Wert aus Feld ukey' where film = 'XXXX'
Dann hast einen Film der diese Leichen als Bilder besitzt. Da ich nicht weiss wo sich die Bilder befinden oder welchem Volume sie angehören, solltest du den Film am besten dann wieder löschen...

Oder gleich im SQL-Fenster:
Code:
delete from bilder where film = ''
Deine Datenbank müsste dann wieder funktionieren.

Zu deiner Frage per Mail: Nein die Volumes werden während einer Reorganisation nicht benötigt.

Gruß, Kai

PS: Die Zuordnung Volumes zu Volume funktioniert seit Version 4.5 ohne Probleme, (August ist mein Zeuge ), so das du wieder untergeordnete Volumes anlegen kannst, damit deine lange Volumeliste übersichtlicher wird...
  #4  
Alt 27.03.2004
nabla
Gast
Beiträge: n/a
Standard gleiches problem mit neuem film

hi,
bei mir kommt auch diese meldung, aber ich habe die light version und kann wohl deshalb keine sql statements abschicken.

wie löse ich mein problem?
ich konnte in der table bilder einige datensätze ohne film zuordnung finden.

danke
  #5  
Alt 27.03.2004
Benutzerbild von Kai
Kai Kai ist offline
Imabas-Entwickler
Admin
Obertroll
Registriert seit: 11.2003
Ort: Holzwickede
Beiträge: 2.756
Kai befindet sich auf einem aufstrebenden Ast
Standard Re: gleiches problem mit neuem film

Hallo,
nimm einfach mal den Key weg, dann wird die Version wieder zur Demoversion, die aber genau das kann was du brauchst...

Gruß, Kai
  #6  
Alt 29.03.2004
nabla
Gast
Beiträge: n/a
Standard Demo - SQL - Anzahl der Bilder egal?

die Demo ist doch auf 2000 bilder begrenzt oder?
hat das auf den SQL Bereich keine Auswirkungen?
  #7  
Alt 29.03.2004
Benutzerbild von Kai
Kai Kai ist offline
Imabas-Entwickler
Admin
Obertroll
Registriert seit: 11.2003
Ort: Holzwickede
Beiträge: 2.756
Kai befindet sich auf einem aufstrebenden Ast
Standard Re: Demo - SQL - Anzahl der Bilder egal?

Nein, das wirkt sich nur auf das "Bilder einlesen" aus. Das geht nur wenn weniger als 2000 Bilder in der Datenbank sind...

Gruß, Kai
  #8  
Alt 29.03.2004
nabla
Gast
Beiträge: n/a
Standard hat funktioniert

aber:

der erste update war etwas merkwürdig
es waren 16 falsche bilder in der DB (mit select zuvor geprüft)
das update hat dann aber nur 8 datensätze aktualisiert, im zweiten versuch dan 4 im dritten 2 und dann einen und noch einen und dann waren alle fertig...

immer genau die hälfte....

eine verbesserung zur problemlösung:
select ukey from filme where caption ='Bezeichnungsfeld'
damit findet es sich schneller...


danke nabla
Thema geschlossen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Refreshproblem beim Hinzufügen neuer Elemente Torsti Bugreports 2 26.01.2007 15:28
Doppelte Bilder nach Reorganisation stefan Imabas Allgemein 6 04.02.2006 21:27
Reorganisation bei Umstieg auf 4.6 ? Roberto Imabas Allgemein 1 02.03.2004 10:33


Powered by vBulletin® Version 3.7.1 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.